Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2.0
    • Component/s: Add Media, Mediathon
    • Labels:
      None
    • Originating Party:
      Customer

      Description

      Liquidsoap supports FLAC

      The problem is I dont think we support detecting the metadata for these types...

      ALAC: http://alac.macosforge.org/

        Issue Links

          Activity

          Daniel James added a comment - - edited

          WAVs don't have standard metadata inside the file like compressed formats do. It's technically possible to embedded metadata: http://www.sno.phy.queensu.ca/~phil/exiftool/TagNames/RIFF.html#Info but this is highly non-standard so it should probably be discouraged. It would be better to recommend FLAC for high quality storage, since this format saves storage space relative to WAV and supports tagging natively.

          AAC and MP4 have distribution problems due to software patents on codecs, so these are best avoided. MP2 is obsolete. Supporting MIDI would require a rendering engine, which is beyond the scope of Airtime (especially if cross-platform support is a goal).

          Paul added a comment - - edited

          From Daniel:

          Hi all,

          Following on from the quality debate, try this in a terminal:

          $ mplayer http://radio.cesnet.cz:8000/cro-d-dur.flac

          It helps to have good monitors, but on any equipment at all, the stereo
          image and dynamic range should be very apparent, compared to typical MP3s.

          Details are at http://www.cesnet.cz/doc/techzpravy/2008/using-flac-encoding/

          This should be very possible to do with Airtime, and would give us
          amazing PR in the broadcast and audiophile communities. The first
          broadcast automation system to offer lossless streaming out of the box?

          Martin Konecny added a comment -

          Would be nice to also have AAC support as some users have asked about this.

          Adam Thomas added a comment -

          On 5/30/11 10:02 AM, Robert Klajn wrote:
          > I really welcome the idea of multiformat input in our child called Airtime.
          >
          > If there are no problems with metadata, than it is perfect.
          >
          > Somehow I got you all wrong – that you can’t have both quality and
          > practicality at the same time, so I reconciled with the fact that we are
          > making B class software for radio station. Maybe ResonanceFM are not our
          > customers or users at the moment, but people similar to them certainly
          > are.
          >
          > Nobody will take you seriously if you on input have mp3 or some lossless
          > format as the most quality format, and haven’t even tried to respect the
          > idea to enter something else in the system besides that.
          >
          > I would like to consider Airtime not only as remote software of radio
          > station in which it won’t ever enter physically, because I still think
          > that there are a lot of stations that don’t upload their musical
          > storages via adsl, but someone actually come to work in radio station,
          > create musical playlists and actively take part in meetings and radio
          > programs.
          >
          >
          > -------------------------
          >
          >
          > Here is a more detailed description of which formats we use in work, and
          > when we do their reduction - from my point of view and my experience:
          >
          > In audio production- in the moment of record creating, audio editing and
          > music (commercials, jingles) postproduction- we all work in big wav
          > format (pc) or aiff (osx).
          >
          >
          > Wav/aiff are basic “master” formats and audio engineers can only work
          > with them since they contain the most information about the recording.
          >
          > On this level, you can’t “save” on space, and you have to try to keep
          > as much information and quality as possible by having bigger sampling
          > speed, never go under 44kHz (radio), 48kHz (tv), 96-192kHz (movies etc).
          >
          > So, wav/aiff is a “mother”-format of all professional studios from which
          > you make all next versions, copies and compressions of audio file
          > (depending on various needs you have: for archiving, further
          > distribution of file etc), and from which we make lower and lower
          > dynamic, frequencies…
          >
          > Big and important radio stations that take care of their standard, sound
          > quality and tradition, still and always use wav/aiff for their capital
          > recordings.
          >
          > Using only lossless formats among professionals and lack of basic master
          > formats in software is considered highly unprofessional, and software is
          > considered as 2^nd or 3^rd class.

          Daniel James added a comment -

          BWF is also a good master format:

          http://en.wikipedia.org/wiki/Broadcast_Wave_Format

          It's WAV compatible, but with a standardised metadata format:

          http://en.wikipedia.org/wiki/IXML

          To be truly 'pro' we should support BWF in Airtime, and therefore WAV as a subset of BWF. This guy has commented on preserving BWF metadata in the conversion to/from FLAC:

          http://www.sounds.wa.com/flac-riff.html

          This requires the use of the --keep-foreign-metadata option when encoding/decoding:

          http://flac.sourceforge.net/documentation_tools_flac.html#flac_options_keep_foreign_metadata

          If we can verify that works 100%, then we can support BWF indirectly by supporting FLAC. On the other hand, there may be stations that don't use a remote workflow, and would prefer to buy more storage than use FLAC compression, just to take one step out of the editorial workflow (e.g. if they have standardised on an editor tool which supports BWF but not FLAC directly).

          My personal feeling is that if they don't have a remote workflow now, they might in future, once they consider the possibilities. So FLAC will be the working exchange format of choice, because we can never have enough bandwidth.

          Daniel James added a comment -

          Requested by ResonanceFM

          Adam Thomas added a comment -
          Cliff Wang added a comment -

          Verified on Airtime 2.2.0+434bcf1, Just support Flac currently


            People

            • Assignee:
              Cliff Wang
              Reporter:
              Paul
              Tested by:
              Cliff Wang
            • Votes:
              5 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 week
                1w
                Remaining:
                Remaining Estimate - 1 week
                1w
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development

                    Poker Sessions

                    This issue is currently not assigned to any Poker Session.